nutzerforum

Nutzerforum.
Informationen, Tipps und Antworten zur Vereinsverwaltung "GS-VEREIN"

Zur Übersicht aller Diskussionen in diesem Forum | Zur Startseite


Unbekannt schrieb am 16.05.2014 19:14:

SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

Nachdem wir es nun endlich geschafft haben 598 fällige Buchungen an das Zahlungsmodul zu übergeben, haben wir leider feststellen müssen, dass für das Feld Kontoinhaber sämtliche Umlaute (incl. ß) nicht übertragen wurden. Was muss ich einstellen, damit auch Umlaute korrekt von GS-Verein an das Zahlungsmodul übergeben werden.

Unbekannt schrieb am 18.05.2014 19:23:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

Hallo,

wenn Du Dich mit den SEPA Vorgaben auseindersetzt, wirst Du feststellen, dass nur der SWIFT Latin Zeichensatz zur Verfügung steht.

Demnach werden deutsche Umlaute entfernt. Beheben kannst Du das, wenn Du Deine Daten in Gs Verein korrekt bereinigst. 

 

Gruß hunter

 

Unbekannt schrieb am 23.01.2015 15:21:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

Hallo,

laut Veröffentlichungen im Internet,

th.giese schrieb am 24.01.2015 09:36:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

Hallo Schatzmeisterin,

ich weiß grad nicht ob es Dir aufgefallen ist, dass der Thread in dem Du schreibst, seinen letzten Eintrag vom Mai 2014 hat. Die ersten Kombinationen SEPA-GS Verein-Zahlungsverkehrsmodul sind alles andere als rund gelaufen.

Das letzte Update des ZVM vom August hat diese und andere ungereimtheiten weitgehend beseitigt. Deutsche Umlaute können nun problemlos verarbeitet werden.

Unbekannt schrieb am 26.01.2015 17:16:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

Hallo,

auch ich hatte ein Problem mit den Umlauten. Beim Übertragen der Namen in den Verwendungszweck wurden diese abgeschnitten.

Ich habe ein Zusatzfeld als Berechnetes Feld eingerichtet mit folgender Formel: STRINGREPLACE(STRINGREPLACE(STRINGREPLACE(STRINGREPLACE($Name,"ö", "oe"),"ü","ue"),"ä","ae"),"ß","ss")+ " " +STRINGREPLACE(STRINGREPLACE(STRINGREPLACE(STRINGREPLACE($Vorname,"ö", "oe"),"ü","ue"),"ä","ae"),"ß","ss")

Dieses Feld übergebe ich dann als Buchungstext für Beiträge. Ich hoffe ich konnte helfen.

Gruß mboehm

th.giese schrieb am 26.01.2015 17:29:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

Hallo mboehm,

micht würde dennoch interessieren ob die Formel vor oder nach dem Update des ZVM vom August 2014 integriert wurde. Seit letzten Sommer über tragen wir Monat für Monat Daten an die Bank ohne irgendwelche Klimmzüge mit Formeln, um Umlaute umzuwandeln.

Unbekannt schrieb am 26.01.2015 18:01:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

Hallo,

Ich habe das neuste ZVM 2015 0.4.1

Wenn ich den Mitgliedsnamen in den Verwendungszweck übertrage werden die Umlaute bei der Buchung unserer Bank ausgelassen. d.h. Es wird beim Mitglied sein Name am Kontoauszug falsch angegeben z.B. aus "Müller" wird "Mller". Was nicht wirklich gut aussieht.

Deshalb habe ich dieses Formelmonster geschaffen.

Gruß mboehm

th.giese schrieb am 26.01.2015 18:50:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

[QUOTE]mboehm schrieb

Ich habe das neuste ZVM 2015 0.4.1[/QUOTE]

Wann kam diese Version denn? Bei mir ist das ZVM noch auf dem Stand vom August 2014. Diese Version müsste ja brandaktuell sein von Anfang Januar.....

 

Unbekannt schrieb am 26.01.2015 18:55:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

 Hallo,

Es ist die Version 2015.0.4.1 vom 4.9.2014

Gruß mboehm

 

th.giese schrieb am 27.01.2015 09:18:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

[QUOTE]mboehm schrieb

Es ist die Version 2015.0.4.1 vom 4.9.2014

[/QUOTE]

Das ist ja eigenartig, bei mir ist die Version 2014 vom 26.08.2014 installiert, eine neuere wird mir auch gar nicht angeboten....

Aber mit dem Umlauten muss ich in der Tat zurückrudern! Die von mir angesporchene Fehlerbehebung bezieht sich auf den Verwendungszweck. Komisch ist nur, dass in den Buchungssätzen innerhalb des ZVM die Umlaute in den Namen noch korrekt angezeigt werden. Dann muss das Entfernen der Umlaute entweder bei der Übertragung an die Bank oder während der Verarbeitung bei den Banken geschehen. Ich habe eben in den Kontoauszügen einzelne Einzüge entdeckt, bei denen die Umlaute geschluckt wurden.

Dann werde ich Dein Formelmonster mal einbinden.

Unbekannt schrieb am 27.02.2015 14:10:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

Hallo mboehm,

die Idee ist super und es klappt auch.

Ich wollte jetzt die Formel um das é (e mit Akut) erweitern. Das funktioniert dann nicht mehr. Im berechneten Feld steht dann "add(....).

Ist die Anzahl der Verschachtelungen mit den "Stringreplace"-Befehl auf 5 beschränkt?

Gruß

Joachim

mbaersch schrieb am 10.03.2015 15:44:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

Hallo,

es hat leider mit der Antwort gedauert, aber: es wird mit der nächsten Fassung (Nein, einen Termin kann ich nicht nennen, weil ich das weder in der Hand noch im Blick habe) vor der Übergabe an den Zahlungsverkehr eine Ersetzung der Umlaute (aus "ü" wird "ue" etc.) vorgenommen, um das Problem zu verringern. 

Grüße aus MG
Markus Baersch

 

 

 

Unbekannt schrieb am 15.12.2015 21:22:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

Hallo mboehm,

Gratulation zu dem Rechenfeld. Funktioniert wirklich gut.
Nur dass ich es nicht schaffe, in dem Verwendungszweck auf das (auf die) Freifelder zu zugreifen. Z.B.: $zu10 für Freifeld 10 verarbeitet das Programm (Version 2013) einfach nicht . Frust.
Wie sprechen Sie das Feld an?

Grüße

Andy

Unbekannt schrieb am 15.12.2015 22:04:

Re: SEPA -> Übergabe an Zahlungsverkehr - Fehlende Umlaute

 Hallo,

ich habe in den Programmeinstellungen unter dem Punkt Buchungen im Feld "Buchungstext Beiträge" folgende Formel stehen : 

Beitrag+"  "+$Zu12

Hier wird auf das berechnete Feld für den Verwendungszweck ausgelesen. 

d.h. im Verwendungszweck steht z.B. " Beitrag Mueller Franz "

Gruß Manfred